hardware

TPM und RAM für ASUS SABERTOOTH Z170 S

Wer das ASUS SABERTOOTH Z170 S mit 64GB RAM bestücken will und dazu ein TPM-Modul nutzen möchte steht vor zwei Herausforderungen.

Zu einem wird in der Regal von einem TPM-Modul für alles ASUS Mainboards gern gesprochen. Das stimmt leider nicht und viele haben plötzlich ein 20-1 (19) PIN TPM Modul in den Händen, aber das Board verfügt über einen 14-1 (13) PIN Anschluss. Wer hier nicht vorab mit dem ASUS Support Kontakt aufnimmt hat ein Problem. Das richtige ASUS Modul trägt die Bezeichnung  90MC0370-M0XBN0 und hat die EAN:  4712900049930. Preislich bewegen wir uns um die 9-12 € für die Sicherheit.

Eine ganze Ecke interessanter wird es bei der maximalen Bestückung mit RAM Speicher. Die Intel-Skylake-Mikroarchitektur kann mit bis zu 64GB Arbeitsspeicher umgehen. Das ist auch die maximal zulässige Bestückung für dieses Motherboard. Das Handbuch führt nur wenige Speicherkits auf, die 64GB haben. Falle Nr. 1 sind die zahlreichen Kit’s von GeIL Memory mit 8 Rigeln, bei einem Board mit 4 Speicherbänken. Hier gilt es höher zu greifen, zum 128GB Kit und es sich zu teilen, wobei ich es Anfang Mai 2016 nirgends finden konnte. Nach etwas Abenteuer mit Kingston Speicher, mehr dazu später, bin ich auf Corsair gekommen. Die von mir erworbenen Corsair CMK64GX4M4A2400C14 sind im Handbuch explizit mit der Version 4.31 angegeben. Die Händler können leider nie sagen, welche Version Sie verkaufen, zum einen liegt das dran, dass die Versionsnummer auf den Speicher aufgedruckt ist und nicht der blickdichten Verpackung, zum anderen können die Versionen innerhalb der Lieferung- en variieren. Mir wurde die Version 3.31 geliefert, nach meinen Abenteuern mit Kingston hatte ich die Hoffnung aufgegeben.

Zunächst hatte ich auch das gleiche Problem, mit dem ich zuvor bei Kingston HX424C15FBK4/64 gekämpft habe. Der Rechner lief hoch bis zum Login und nach der Eingabe des Kennworts nur noch schwarzer Bildschirm und kein Signal von der Grafikkarte mehr. Nach zig Änderungen im UEFI (BIOS) und ewigen hin und her, stellte sich heraus, dass eins der tollen ASUS Tools das Problem produziert. Nach der Deinstallation der gesamten ASUS Tools waren alle Probleme weg und das System läuft stabil seither.

exchange

Probleme mit der Bereitstellung einer neuen Exchange Datenbank

Vor ein paar Tagen hatte ich Probleme bei einem Kunden eine neue Exchange Datenbank bereitzustellen. Die Bereitstellung über die Exchange Management Shell:

New-MailboxDatabase -Server 'EXCHANGE' -Name 'NEW DATABASE' -EdbFilePath 'E:\EX-DATABASE\NEW DATABASE\NEW DATABASE.edb' -LogFolderPath 'E:\EX-LOGS\NEW DATABASE'

führte zum folgenden Fehler:

Fehler:
Die angegebene Datenbank konnte nicht eingebunden werden. Angegebene Datenbank: NEW DATABASE; Fehlercode: Fehler bei Active Manager-Vorgang: Fehler bei der Datenbankaktion: Fehler bei Vorgang mit folgender Meldung: MapiExceptionNotFound: Unable to mount database. (hr=0x8004010f, ec=-2147221233)
.. [Datenbank: NEW DATABASE, Server: EXCHANGE.domain.tld].
Fehler bei Active Manager-Vorgang: Fehler bei der Datenbankaktion: Fehler bei Vorgang mit folgender Meldung: MapiExceptionNotFound: Unable to mount database. (hr=0x8004010f, ec=-2147221233)
.. [Datenbank: NEW DATABASE, Server: EXCHANGE.domain.tld]
Fehler bei Active Manager-Vorgang: Fehler bei Vorgang mit folgender Meldung: MapiExceptionNotFound: Unable to mount database. (hr=0x8004010f, ec=-2147221233)
. [Server: EXCHANGE.domain.tld]
MapiExceptionNotFound: Unable to mount database. (hr=0x8004010f, ec=-2147221233)
Ausführungsversuch eines Exchange-Verwaltungsshellbefehls:
mount-database -Identity 'NEW DATABASE'

Die angegebenen Ordner wurden zwar immer erstellt, aber eine Datenbankdatei wurde nicht bereitgestellt und somit auch nicht eingebunden.

Die Lösung war etwas krank und machte im ersten Moment keinen Sinn, aber letztlich wurde eine Datenbankdatei angelegt und konnte eingebunden und benutzt werden. In der Exchange Management Console habe ich die Eigenschaften der betroffenen Datenbank aufgerufen, um dann im Reiter Clienteinstellungen die Standarddatenbank für öffentliche Ordner und das Offlineadressbuch anzugeben und zu bestätigen. Danach kann mit einem rechts Klick die Datenbank eingebunden werden, bzw. wird eine Datenbankdatei erstellt und in Exchange eingebunden. Die Datenbank ist voll funktionsfähig und bereitet auch mit über 100GB Postfachdaten keine Probleme.

auto mobilgeräte

Android Auto im VW Discover Pro 2015/2016

Das neue Auto war bestellt und Android Auto war mit an Board, die Freude war groß. Neben Android Auto wird natürlich ein Smartphone mit Android ab Version 5.0 benötigt, sowie die Android Auto App und ein entsprechendes Adapterkabel. Die Inbetriebnahme ist relativ simpel, App runterladen, Kabel mit Fahrzeug verbinden und im Discover Pro über Menü -> Apps -> Android Auto wählen. Alle weiteren Schritte werden dann übersichtlich im Display des Smartphones und Radios angezeigt, kein Hexenwerk.

Das Android Auto bei VW aktuell nichts weiter als ein Add-on ist, wird einem recht schnell klar, wenn man es das erste Mal einsetzt. Ja, es gibt keinen dedizierten Knopf für Android Auto, es muss der Umweg über Menü gegangen werden. Die Android Auto Navigation (Google Maps) blendet nichts ein im Display des Tachos. Auch die Sprachwahltaste am Lenkrad aktiviert nicht die Google Sprachunterstützung, sondern die VW eigene. Alles in allem, läuft das System, aber man merkt sein Add-on Charakter sehr deutlich und wird es vielleicht doch nicht so einsetzen, wie es zunächst gewünscht/geplant wäre. Als einfacher Wunsch und Beispiel, ich steige morgens ins Auto, verbinde mein Smartphone und bekomme direkt auf dem großen Display des Discover Pro die Meldung, die Strecke B heute zu Arbeit zu nehmen, da Strecke A Staus enthält und eine längere Zeit benötigt wird. Natürlich kann diese Prüfung wie bisher auf dem Smartphone vorab vorgenommen werden, aber man kauft auch keinen Fernseher mit Fernbedienung und schaltet letztlich die Kanäle am Fernseher selber um.

Fazit von Android Auto in VW Modellen 2015/2016: Nettes Add-on, aber mit den Werbevideos von Google hat es wenig zu tun. Warten wir ab, wie es mit Updates des Systems weiter geht.

hardware internet

Side-to-Side VPN – Sophos UTM und FritzBOX

VPN Einstellungen in der UTM

Neulich stand ich tatsächlich vor dem Thema ein Heimarbeitsplatz, ausgestattet mit einer FritzBOX, an die Firma anzubinden. Der Betrieb selber verfügt über eine Sophos UTM (vormals Astaro ASG) Firewall. Die Herausforderung bestand eher darin herauszufinden, wie man eine gute Verschlüsselung für diese VPN-Verbindung einstellt und sich nicht mit der 3DES Verschlüsselung zufrieden zu geben, die oft im Netz beschrieben ist. Es sollte schon AES 256 zu Einsatz kommen.

Der Assistent in der FritzBOX ist so rudimentär, dass er für diesen Zweck vollkommen ungeeignet ist. Also musste eine Konfigurationsdatei erstellt und verwendet werden. Hinzu kam ein Fehler in der Dokumentation auf der AVM Seite. Die dort beschriebene Einstellung um mehrere SA zu verwenden funktionierte nicht. Als Lösung habe ich mehrere VPNs in die Konfigurationsdatei eingebetet und so zum laufen bekommen.
vpncfg {
connections {
enabled = yes;
conn_type = conntype_lan;
name = " Firmenzentrale";
always_renew = yes;
reject_not_encrypted = no;
dont_filter_netbios = yes;
localip = 0.0.0.0;
local_virtualip = 0.0.0.0;
remoteip = WAN IP DER UTM;
remote_virtualip = 0.0.0.0;
localid {
ipaddr = WAN IP DER FRITZBOX;
}
remoteid {
ipaddr = WAN IP DER UTM;
}
mode = phase1_mode_idp;
phase1ss = "alt/all/all";
keytype = connkeytype_pre_shared;
key = "puep_123";
cert_do_server_auth = no;
use_nat_t = yes;
use_xauth = no;
use_cfgmode = no;
phase2localid {
ipnet {
ipaddr = 192.168.178.0;
mask = 255.255.255.0;
}
}
phase2ss = "esp-aes256-3des-sha/ah-no/comp-lzs-no/pfs";
accesslist = "permit ip any NETZ IP + MASKE HINTER DER UTM (z.B. 192.168.0.0 255.255.255.0)";
}
ike_forward_rules = "udp 0.0.0.0:500 0.0.0.0:500",
"udp 0.0.0.0:4500 0.0.0.0:4500";
}

Eine hervorragende Übersicht über mögliche Parameter für die FritzBOX Konfigurationsdatei bietet dieser Beitrag.

exchange windows

Namens Autovervollständigung von Outlook 200x/2010 in 2013/2016 übertragen

Die so genannten gecachten Namen in Outlook sind ein Segen und Fluch eines jeden Administrators. Nicht selten sorgt diese Funktion von Outlook für Probleme und Ärger. Sei es durch eine an falschen Empfänger gesendete Mail, aufgrund von Unaufmerksamkeit bei der Nutzung der Autovervollständigung, bis hin zur gecachten Adressen, die aufgrund einer Migration nicht mehr stimmen. Der Ärger ist hier nicht selten und kann im schlimmsten Fall über leeren der gesamten Autovervollständigung bereinigt werden.

Trotzdem kann es zur der Anforderung kommen nach einem Wechsel von Outlook 200x/2010 hin zur einem aktuellen 2013/2016, dass die besagte Autovervollständigung unbedingt übernommen werden soll. Hier hat Microsoft im knowledge base Artikel KB2806550 recht ausführlich die Migration beschrieben. Bei eine größeren Anzahl der Benutzer wird man mit dieser Arbeit kein Spaß haben, aber eine Hand voll glücklich machen können.