0x00000002 & 0x0000007e – x64 Problem mit Drucker

Drucker auf dem Printserver einrichten und ab in die Gruppenrichtlinien, die Richtlinie über die gesamte Domäne verteilen und fertig sind die Drucker an allen Arbeitsplätzen.
So einfach sollte es sein, aber leider funktionierte es auf den Terminalservern (Windows 2008 R2) nicht sauber. Zunächst wollte ein Drucker nicht ganz. Beim Druckversuch kam immer die Meldung: Die Testseite konnte nicht gedruckt werden. Soll die Druckproblembehandlung angezeigt werden? Der Vorgang konnte nicht abgeschlossen werden (Fehler 0x00000002).
Wenn ich den Drucker dann manuell gelöscht habe und ihn versucht habe neu hinzuzufügen klappte es auch nicht mehr und ich bekam die Meldung: Druckerverbindung kann nicht hergestellt werden.Fehler bei Vorgang: 0x0000007e.
Zunächst betraf es nur ein Dell Drucker und ich konnte der Mitarbeiterin anderweitig helfen (lokaler Treiber). Doch nach und nach kamen weitere Drucker dazu, zunächst von Dell, aber später auch schon Canon.
Also hilft alles nichts und ab auf Recherche. Der häufigste Tipp war es aktuelle Treiber vom Hersteller zu verwenden, da ich aber nie CDs verwende und immer nur die neusten Treiber nutze, war das eine Niete. Alle anderen Tipps brachten auch keinen Erfolg, also ab zum Microsoft Support. Nach ca. zwei Tagen und etwas hin und her Kommunikation war er gefunden, der Patch gegen dieses Problem.
Das Problem scheint nur bei Windows 7 und Windows 2008 R2 Systemen aufzutreten und kann durch einspielen des Patches, aus dem Microsoft Knowledge Base Artikel KB982728, behoben werden.
Nach der Installation des Patches und dem durchstarten der Server war der Fehler beseitigt und es lief alles wieder wie geplant.

6 Comments

  • 11. Oktober 2010 - 11:01 | Permalink

    Das Problem kenne ich, gleich mal checken ob die Fehlermeldung die selbe ist.

  • 16. November 2010 - 20:25 | Permalink

    ähnliches Problem: nach einiger Zeit sind auf dem 2008 R2 Server die im Netzwerk von XP Rechnern freigegebenen Drucker bis zum Serverneustart nicht mehr anzusprechen. Beim Entfernen und Neuverbinden gibt es auch die 0x00000002.

    Hab jetzt mal den Hotfix installiert. Mal sehen was es bringt. Das ist auf jeden Fall der erste nützliche Hinweis, der mir bisher untergekommen ist.

  • olli
    3. Mai 2011 - 21:17 | Permalink

    Ich hatte das Selbe Problem, es trat vollkommen unvermittelt auf. Ich vermute das SP1 von Windows 7 als Übeltäter, sonst hatte ich nichts an den Rechnern verändert. Abhilfe brachte der Patch leider nicht, da er sich nicht installieren ließ. Komischerweise brachte aber ein Update des Internet Explorers abhilfe bei dem Problem, der Drucker lies sich wieder installieren. Vielleicht hilft der Tipp ja dem einen oder anderen.

  • JMB
    26. Mai 2011 - 12:22 | Permalink

    Ich hatte das gleiche Problem und hab nach intensiver Recherche auch was gefunden. Einfach den Regkey auf dem Server löschen, der den Drucker freigibt. Hat bei mir geholfen…

    HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlPrintPrintersPRINTERNAMECopyFilesBIDI

  • 24. August 2012 - 11:55 | Permalink

    Hi,
    Sorry das ich einen so alten Thread nochmal belebe, aber wir haben genau deas gleiche Problem.Nur leider lässt sich auch durch das äbndern/löschen des reg-Eintrags nichts bewirken. Vieleicht hat jemand noch eine hilfreiche Idee. Unser Drucker ist ein hp cp3525 unser System: SBS2011 / Win7Pro
    Danke

  • M. Henneken
    16. April 2014 - 11:54 | Permalink

    Hallo!
    Ich habe ein ähnliches Problem mit einem LaserJet P2055. Dieser Drucker ist noch auf einem Windows XP (32-Bit) installiert und soll per Freigabe auf einem Windows 7 (64-Bit) laufen. Der Drucker wird gefunden, aber beim Verbinden wird abgebrochen und die Fehlermeldung 0x00000007e erscheint.
    Der Fehler kommt, laut Microsoft, von einem Portierungsfehler von einem 32-Bit auf ein 64-Bit System. Der Windows XP Rechner soll zwar bald ersetzt werden, aber wenn sich für diesen kurzen Zeitraum noch eine schnelle Lösung finden würde, könnte ich schon mal drucken.

    Der Tipp mit dem Registry Eintrag funktioniert NICHT, da der Drucker erst gar nicht dort aufgeführt wird.

    Wenn noch jemand eine Lösung hat, wäre das super!

    Mit freundlichen Grüßen,
    M. Henneken

  • Schreibe einen Kommentar

    Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.